Could not load class InvokeApplicationInterceptor

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Could not load class InvokeApplicationInterceptor

xamba
Hi all,

I'm trying to integrate Struts 2 , Spring and Hibernate JPA.
Everything is ok but when I want to startup the server (Tomcat 6) the console throw the following exception:

GRAVE: Actual exception
Could not load class org.apache.struts2.jsf.FacesSetupInterceptor. Perhaps it exists but certain dependencies are not available? - interceptor - ...

I copy the librarys I have imported in my project:

commons-logging.jar
antlr-2.7.2.jar
commons-beanutils-1.6.jar
commons-chain-1.1.jar
freemarker-2.3.8.jar
ognl-2.6.11.jar
struts2-core-2.0.11.2.jar
struts2-spring-plugin-2.0.11.2.jar
tiles-api-2.0.4.jar
tiles-core-2.0.4.jar
tiles-jsp-2.0.4.jar
xwork-2.0.5.jar
spring.jar
antlr.jar
cglib.jar
commons-collections.jar
dom4j.jar
ejb3-persistence.jar
mysql-connector-java-5.1.6.jar
hibernate-entitymanager.jar
hibernate-annotations.jar
jboss-archive-browsing.jar
hibernate-commons-annotations.jar
asm-2.2.3.jar
asm-commons-2.2.3.jar
asm-util-2.2.3.jar
aspectjrt.jar
aspectjweaver.jar
javassist.jar
asm-attrs.jar
cglib-nodep-2.1_3.jar
commons-collections-3.2.jar
hibernate.jar
spring-context.jar
struts2-jsf-plugin-2.0.11.2.jar


Hope anyone knows what happen!!

thank you guys!
Reply | Threaded
Open this post in threaded view
|

Re: Could not load class InvokeApplicationInterceptor

xamba
Ok,

I have solved  the problem, I just downloaded the spring dependecies for tomcat, they are: naming-resources.jar and catalina.jar and It is working fine!

bye